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Introduction 
The Re-Order Analysis Import function allows inventory re-order parameters to be loaded into PharmaClik 
Rx from the Re-Order Analysis Report.   
 
Purpose: 

• This is useful for pharmacies that wish to begin monitoring inventory. 
• Allows existing inventory users to re-evaluate their current re-order parameters. 

Re-Order Analysis Report 
The Re-order Analysis Report recommends inventory re-order points and re-order quantities based on 
average daily product usage over a selected time period.  The report lists all products dispensed during the 
report period, regardless of whether they are monitored in inventory (the default report period is the previous 
3 calendar months).  This is useful to pharmacies that wish to begin monitoring inventory and allows existing 
inventory users to re-evaluate their current re-order parameters. 

Set the report criteria 
To generate the report, both the Min On Hand Days and Max On Hand Days must be specified: 

• Min On Hand: The minimum number of days’ worth of stock that the pharmacy would like to keep on 
hand.  The default value is 7.  This number will be used to calculate the suggested re-order point. 

• Max On Hand: The maximum number of days’ worth of stock that the pharmacy would like to keep 
on hand.  The default value is 10.  This value will be used to calculate the suggested re-order 
amount. 

The extended report option Only show re-order differences indicates whether all products should be 
included on the report.   

• When the checkbox is OFF, all products dispensed during the report period will be listed on the 
report.   

• When the checkbox is ON, the report will exclude monitored products where the suggested re-order 
values equal the current re-order values (i.e. Current Re-Order Point = Suggested Re-Order AND 
Current Re-Order # Packs = Suggested Re-Order # Packs). 

 
Ex. Only show re-order differences is selected.  A monitored product’s Current Re-Order 

Point = 150 and the Current Re-Order # Packs = 1.  When the report is generated, the 
Suggested Re-Order Point = 150 and the Suggested Re-Order # Packs = 1.  Since the 
current and the suggested values are both the same, this product will not be included in the 
report. 

 

The report can be generated for a specific drug, manufacturer, supplier, custom class, therapeutic class, or 
for a combination of these criteria.  When one or more of these criteria are specified, it will be indicated near 
the top of the report. 
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Advanced criteria options can be accessed by selecting the Advanced tab.  These options allow only 
specific drug or manufacturer names to be included in the report.  This is useful if your shelves are arranged 
alphabetically by generic name, trade name, or manufacturer.  The advanced options are: 

• Generic Names beginning with the letter: If you would like to see data for drugs that have generic 
names beginning with a specific letter, enter the letter in this field. 

• Trade Names beginning with the letter: If you would like to see data for drugs that have trade 
names beginning with a specific letter, enter the letter in this field. 

• Manufacturers beginning with the letter: If you would like to see data for drugs that have a 
manufacturer code beginning with a specific letter, enter the letter in this field. 

Decide how to sort the report 
Several sort options are available; the selected option will be shown in the Sorted By field on the report.  
The sort options are: 

• Acquisition Cost: Products will be listed by acquisition cost in descending order.  Products with the 
highest Acq Cost will be at the top of the report and those with no Acq Cost will be at the end of the 
report. 

• DIN: Products will be listed by DIN in ascending order. 

• Generic Name: Products will be listed in alphabetical order based on the drug’s generic name.  This 
is the default sort option. 

• Manufacturer, Generic Name: Products will be listed in alphabetical order based on the 
manufacturer code.  Within each manufacturer, the products will be listed alphabetically by generic 
name. 

• Manufacturer, Trade Name: Products will be listed in alphabetical order based on the manufacturer 
code.  Within each manufacturer, the products will be listed alphabetically by trade name. 

• On Hand: Products will be listed by the On Hand amount in descending order.  Products with the 
highest On Hand amount will be at the top of the report and those that are not monitored will be at the 
end of the report. 

• Qty Disp: Products will be listed by the Qty Disp value in descending order.  Products with the 
highest quantity dispensed will be at the top of the report and those with the lowest quantity 
dispensed will be at the end of the report. 

• Supplier Cost: Products will be listed by the Sup Cost in descending order.  Products with the 
highest supplier cost will be at the top of the report and those with no supplier cost will be at the end 
of the report. 

• Trade Name: Products will be listed in alphabetical order based on the drug’s trade name. 
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When the Extended report criteria Only show re-order differences is ON, a note near the top of the report 
indicates ‘Only show products with differences between the current re-order values and the suggested re-
order values.  No note is printed when Only show re-order differences is OFF. 

Min Days On Hand The minimum number of days’ worth of inventory to keep on hand, taken from the 
setting in the Min On Hand field in the report criteria. 

Max Days On Hand The maximum number of days’ worth of inventory to keep on hand, taken from the 
setting in the Max On Hand field in the report criteria. 

DIN The DIN for the dispensed drug. 

Generic Name The generic name of the drug. 

Trade Name The trade name of the drug. 

Strength The strength of the drug. 

Form The dosage form of the drug. 



Pharmacy Technology Solutions  |  Re-Order Analysis Import User Guide 
 
 
 

 
 
 
© 2019. McKesson Canada, all rights reserved  Page 5 of 11 
 

Mfr The 3-letter manufacturer code for the drug. 

Pack Size The package size from which prescriptions have been dispensed during the report 
period. 

Qty Disp The amount of the drug that has been dispensed from the corresponding pack 
size during the report period. 

On Hand The current on hand amount for the pack size, as taken from Drug > Inventory. 
If the product is not monitored, N/A will be displayed.  This indicates the product 
has been dispensed during the report period, but it is not monitored in inventory. 

Current Re-Order The current re-order point for the pack size.  This is taken from the Re-Order  
Point Point field in Drug > Inventory. 

Current Re-Order The current re-order # packs for the pack size.  This is taken from the Re-Order #  
# Packs  Packs field in Drug > Inventory. 

Suggested Re-Order The suggested re-order point, based on the average daily usage for the report  
Point  period and the minimum number of days of on hand inventory.  The final value 

from the calculation is rounded to the nearest whole number. 
 Calculation:               Qty Disp                x Min Days On Hand = Suggested Re-Order Point 
  # Days in Report Period 

Suggested Re-Order The suggested re-order # packs, based on the average daily usage for the report  
# Packs period and the maximum number of days of on hand inventory. The final value 

from the calculation is rounded to the nearest whole number.  When the final 
value is less than 1 (ex. 0.3), the value is rounded up to 1. 
When the Pack Size is 0, the Suggested Re-Order # Packs cannot be 
determined, therefore an asterisk is displayed beside the quantity.  This indicates 
that the value is a Suggested Re-Order Qty, not a Re-Order # Packs (the 
asterisk is referenced at the bottom of each page).  If the user wishes to monitor 
pack sizes for this drug, divide the quantity by the appropriate pack size to 
determine the Suggested Re-Order # Packs. 

 Calculation:                Qty Disp               x Max Days On Hand = Max On Hand 
 # Days in Report Period 
 Max On Hand – Suggested Re-Order Point = Suggested Re-Order Qty 

Suggested Re-Order Qty = Suggested Re-Order # Packs 
         Pack Size 

Sup Cost The per unit supplier price for the pack size.  This is taken from the Price (ut) field 
for the Rank 1 supplier in the Pack Detail section of Drug > Inventory. 

Acq Cost The per unit acquisition cost for the pack size.  This is taken from the Acq Cost 
(ut) field in the Pack Detail section of Drug > Inventory.  If the Acq Cost (ut) field 
is blank in PharmaClik Rx, it will be blank on the report. 
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Using the Re-Order Analysis Import 
Before using the Re-Order Analysis Import function, verify that the Reorder Analysis 
Import icon is in the McKesson PTS Utilities folder on your server’s desktop. 
 
This icon is used to import the Suggested Re-Order Point and Suggested Re-Order # 
Packs from the Re-Order Analysis Report. 
 
If the icon is not located in the folder, contact PTS Customer Care at 1-800-387-6093. 
 
 

 
 

** YOUR EXPORTED FILE MUST BE NAMED REORDER.TXT ** 
 

PART 1: Generate the Re-Order Analysis Report 
1. Open PharmaClik Rx Reports on the SERVER. 
2. Highlight Re-Order Analysis in the Select a Report window. 
3. Select Next. 
4. Enter the Start Date and End Date. 
5. Enter the Min On Hand Days. 
6. Enter the Max On Hand Days (this defaults to 10). 
7. Enter any additional report criteria or advanced report criteria.  (Optional) 
8. Select the Sort Options tab. 
9. Select the method in which the report should be sorted. 
10. Select Preview. 
11. Select Print once the report displays on the screen. 
12. Select Save. 
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13. The Save As window opens.  The file must be saved in the C: drive on the SERVER in the path: 
a. C:\REORDER.TXT 
b. Select (C:) from the Save in drop-down list.   
c. Enter REORDER.TXT in the File name field.   
d. Select CSV from the Save as type drop-down list.  

 
14. Select Save. If a REORDER.TXT file already exists in the folder, a prompt displays to confirm if you 

want to replace the existing file.   
15. Select Yes. 

PART 2: Review and Edit the Import File 
Before importing the file into PharmaClik Rx, review and edit the suggested re-order parameters for each 
drug listed on the report (optional).   

 

IMPORTANT! 
• The report can be edited in a text file or in a Microsoft Excel spreadsheet – 

instructions for each are provided on the following pages. 
• The report CANNOT be edited from C:\ 
• To edit the file, you can modify it from any other file location (e.g. the desktop, 

My Documents, OneDrive or move it to a different computer). 

To Edit the Import File in a Text File 
1. Minimize all applications on the server. 
2. Select the Windows or Start button on the Taskbar. 
3. Open Notepad. Notepad opens in a blank window.   
4. Select File in the upper left side of the window. 
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5. Select Open. The Open window displays.  The file is saved in the C: drive on the SERVER.   
a. Select (C:) from the Look in drop-down list.   
b. Highlight REORDER.TXT in the list of folder and files located in center of the window.  The 

File name field should say REORDER.TXT. 

 
6. Select Open. The import file opens in the Notepad window.  The products are listed in the same 

order as they are on the printed version of the report.  On the screen, the columns in the report are 
separated by commas.  The Suggested Re-Order Point and Suggested Re-Order # Packs are 
displayed to the left of the cost information.   

 
Ex. For the drug shown below, the 5.000000 is the Suggested Re-Order Point and the 

2.000000 is the Suggested Re-Order # Packs. 

 

 

 Tip: It is easiest to view the file when Word Wrap is turned off.  Select Edit at the top of the 
Notepad window.  If there is a checkmark to the left of Word Wrap, then Word Wrap is 
turned ON.  To turn Word Wrap off, select Word Wrap in the Edit menu.  The data in the 
window resets to display the information for each drug on a single line. 

7. Using the printed version of the Re-Order Analysis report for reference, review and update the 
Suggested Re-Order Point and the Suggested Re-Order # Packs. 

8. Save the file periodically by selecting File > Save.   
9. When you are finished editing the file, save it one more time and then exit Notepad.   
10. To exit, select File > Exit. 

To Edit the Import File in Microsoft Excel 
An alternative, and easier, method of editing the import file is to use a Microsoft Excel spreadsheet.  If you 
do not have Microsoft Excel loaded on your server, you can save the file and edit it on a different computer.  
Once the editing is complete, resave the file on the server. 
 

1. Open Microsoft Excel. 
2. Select File in the upper left side of the Excel window. 
3. Select Open. The Open window displays.   
4. Find and highlight REORDER.TXT in the list of folder and files located in center of the window.  The 

File name field should say REORDER.TXT. 
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5. Select Open.  The Text Import Wizard opens.  The first window is Step 1 of 3.  As shown in the 
screen below;  

• Delimited should be selected under Original date type.   
• Start import at row should be set to 1.   
• File Origin should be set to Windows (ANSI).   

 
6. Select Next. Text Import Wizard – Step 2 of 3 displays.   

a. Select Comma under Delimiters.   
b. Deselect any other checkboxes.   
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7. Select Next. Text Import Wizard – Step 3 of 3 displays.  Do not make any changes in this window.   

 

8. Select Finish. The import file opens in Microsoft Excel.  The Suggested Re-Order Point is displayed 
in column N.  The Suggested Re-Order # Packs is displayed in column P.   

9. Using the printed version of the Re-Order Analysis report for reference, review and update the 
Suggested Re-Order Point and the Suggested Re-Order # Packs for each product.   

 Tip: Manual calculations are required when the Suggested Re-Order # Packs has an asterisk 
on the printed report.  The asterisk indicates that the amount is a Re-Order Quantity.  To 
calculate the appropriate Re-Order # Packs, divide the Re-Order Quantity by the pack 
size that you wish to monitor. 

10. Save the file periodically by selecting File > Save.  When you are finished editing the file, save it one 
more time and then exit Microsoft Excel.   

11. To exit, select File > Exit. 
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PART 3: Apply the Import File 
The edited import file must be applied on the server.  If the file was edited on a different computer, move the 
file back to the SERVER and resave it as C:\REORDER.TXT.   
 

 

IMPORTANT! 
The import runs as soon as you double-click the Re-Order Analysis Import Utility 
icon.  Make sure C:\REORDER.TXT is in place before you start. 

 
1. Minimize all applications on the SERVER. 
2. Open the McKesson PTS Utilities folder. 
3. Double-click on the Reorder Analysis Import Utility on the desktop. 

Some windows will flash on the screen. 

 
Note: Do not touch the computer during this process. The 

windows will close as soon as the file has been applied. 
 

In PharmaClik Rx, the Re-Order Point and Re-Order # Packs will be updated for each 
MONITORED product that was included in the import file and the Re-Order Analysis Report.  

4. Verify some of the drugs that were in your import, to ensure it was successful. 
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